web-dev-qa-db-de.com

Android - "Analyse der Daten für Android-21 fehlgeschlagen"

Hatte den folgenden Fehler in Eclipse nach der Installation Android 5.0 (SDK 21)

"Beim Laden der Daten für Android 5.0" ist ein Problem aufgetreten.

Das Parsen der Daten für Android-21 ist fehlgeschlagen
nicht unterstützte major.minor-Version 51.0

44
warbi

Versuchen Sie, JDK 1.8 zu installieren und Eclipse neu zu laden.

http://www.Oracle.com/technetwork/Java/javase/downloads/jdk8-downloads-2133151.html

54
warbi

Anfangs hatte ich das gleiche Problem. Ich habe ein Upgrade auf JDK1.7 durchgeführt. Problem weiterhin bestehen. Dies liegt an der Tatsache, dass Eclipse für einige Zeit das Standard-SDK als 1.6 verwendet. So lösen Sie dieses Problem:

  1. Ändern Sie den Umgebungspfad in Punkt 1.7/1.8
  2. Öffne Eclipse und gehe zur Registerkarte "Fenster" -> "Einstellungen"
  3. Gehen Sie zu Java-> complier und setzen Sie die Compiler-Kompatibilitätsstufe auf 1.7 und drücken Sie Apply.
  4. Dann gehen Sie zu Installed JRE Section. Überprüfen Sie, ob das installierte JDK aufgelistet und in der Liste ausgewählt ist. Wenn nicht aufgelistet, geben Sie den manuellen Pfad über die Suche an. Wählen Sie dann die jdk-Version aus und entfernen Sie andere Versionen aus der Liste.
  5. gehen Sie in der installierten JRE zur Ausführungsumgebung und wählen Sie die beabsichtigte Java se-Version aus und überprüfen Sie sie im kompatiblen Abschnitt
  6. Drückt ok und startet Eclipse neu.

Dies sollte das Problem beheben.

11
Amit

Ich habe alle oben genannten Schritte ausprobiert, konnte das Problem jedoch nicht lösen. Nach einigen Recherchen habe ich die Lösung meines Problems gefunden.

überprüfen Sie die Datei Eclipse.ini auf -vm (z. B. "C:/Programme/Java/jre7/bin/javaw.exe").

ich habe auch das Problem, das Sie sagten und ich fand, dass Eclipse mit Java6 gestartet wird. Nachdem ich Java7 geändert habe, gibt es keinen solchen Fehlerdialog.

  • Daher muss das SDK auf 1.8 oder 1.7 aktualisiert werden.
  • setze den Compiler auf 1.7 oder 1.8.
  • überprüfen Sie dann Eclipse.ini
3
Tarun Sharma

Die Installation von JDK 1.8 und das Neuladen von Eclipse haben bei mir funktioniert

http://www.Oracle.com/technetwork/Java/javase/downloads/jdk8-downloads-2133151.html

0
Jais Joy