web-dev-qa-db-de.com

Android AVD zeigt nichts an. nur "Android" in der Mitte des Bildschirms

Ich bin ein Android-Neuling! bitte helfen.

Ich habe die Einführung zu Googles befolgt und konnte alles problemlos installieren. aber wenn ich versuche, das HelloAndroid-Beispiel auszuführen, startet der avd, zeigt aber nichts an.

kegel jemand bitte helfen?

37
Arturski

Nachdem Sie eine AVD erstellt haben, dauert die Initialisierung wirklich lange. Auf meinem weniger als zwei Jahre alten Core2Duo 2,8 GHz mit Win7x64 und 4 GB RAM dauerte die Initialisierung einer Version 2.2 mindestens 5 bis 10 Minuten (wenn nicht länger). Sobald die Initialisierung beginnt, können Sie das Logcat im DDMS-Bedienfeld von Eclipse beobachten und beobachten, wie alle Apps im Emulator entpackt und installiert werden.

47
Morrison Chang

Es ist schneller, die Datei mit einem USB-Kabel auf das Telefon zu exportieren. Installieren Sie sie, indem Sie die Datei .apk mit einem Dateimanager auswählen, und starten Sie sie von Ihrem Telefon aus. Dies gibt Ihnen auch "echte" Simulationen der App. Es ist auch schneller. Wenn Ihre App Mängel aufweist, können Sie sie schneller auf Ihrem Telefon finden. Warten Sie, bis die AVD geladen ist, und Ihre App funktioniert nicht!

  1. Gehen Sie zu Datei -> Exportieren , wählen Sie den Ordner Android und dann die Anwendung Android.
  2. Wählen Sie auf der nächsten Seite die Anwendung aus, die Sie exportieren möchten.
  3. Erstellen Sie eine Schlüsseldatei und einen Alias.
  4. Werfen Sie Ihr Telefon aus, öffnen Sie den gewünschten Dateimanager und klicken Sie auf die App.
  5. Mit dem Android-Paketinstallationsprogramm ausführen, müssen Sie in Ihren Einstellungen keine Marktanwendungsinstallation aktivieren
  6. Öffnen Sie die App, nachdem die Installation abgeschlossen ist.
9

Sie können jederzeit 'Adb Shell' oder 'Adb Logcat' in einem anderen Fenster ausführen, um zu sehen, was passiert ...

7
Matthieu

Ich hatte das gleiche Problem, aber ich habe es behoben, indem ich .AndroidOrdner aus C:\Users\User\löschte.

Jedes Mal, wenn ich Eclipse oder AVD starte, lösche ich diesen Ordner. Danach wirkt alles charmant.

OPTIONAL: Wenn das Problem weiterhin besteht, versuchen Sie, den NEXUS S AVD zu klonen.

2
zackygaurav

Ich hatte das gleiche Problem. Ich hatte mein System nach der Installation des ADT-Plugins nicht neu gestartet. Nach dem Neustart meines Systems hat es gut funktioniert.

1
chdt

Wie lange hast du darauf gewartet? Auf meinem (allerdings älteren und langsameren) Heimcomputer kann es einige Zeit dauern, bis der AVD das erste Mal initialisiert wird. Ich habe es gerade ausprobiert und es dauert etwa 90 Sekunden, bis das "Android" in der Mitte des Bildschirms durch den Startbildschirm ersetzt wird. Anschließend dauert es etwa 30 Sekunden, bis die Anwendung ausgeführt wird.

1
Niall C.

Ja, es hat zu lange gedauert, um zu starten .... Versuchen Sie, die Visualisierung in den System-BIOS-Einstellungen einzuschalten .... Nach dem Wechsel dauerte es 3 Minuten, um zu initiieren

Systemspezifikationen: i5 Dual Core 4 GB Nvidia 2G

0
aki237

Gelegentlich habe ich festgestellt, dass es einfach auf dem Ladebildschirm aufhängt, und wenn Sie es neu starten, wird es richtig angezeigt. Außerdem kann es aus dem Speicher sehr lange dauern, bis das erste Mal geladen wird.

Stoppen Sie den Emulator -> ADV Manager öffnen -> Virtuelles Gerät bearbeiten -> Klicken Sie auf Erweiterte Einstellungen anzeigen -> Ram-Größe 512 MB einstellen -> Emulator starten

0
yakup_y

Für Ubuntu (ich verwende Xubuntu):

Meine Android Virtual Devices wurden nicht gestartet, da ich NVIDIA-Treiber für Ubuntu verwendet habe. Nachdem der Treiber auf Nouveau geändert wurde, startete er in 15 Sekunden.

Gehen Sie zu "Einstellungsmanager" -> Software & aktualisiert -> Zusätzliche Treiber: "X.org x Server verwenden - Nouveau-Anzeigetreiber (Open Source)"

NVIDIA F # U http://www.youtube.com/watch?v=55XVnJ_0qhg

0
Andrzej Rehmann