web-dev-qa-db-de.com

Android-Emulator kann nicht gestartet werden

Ich habe ein Android-Emulatorgerät erstellt und versucht, es auszuführen. Ich habe folgende Fehler erhalten:

02-18 05:46:39.070        99-99/? E/SurfaceFlinger﹕ ERROR: failed to open framebuffer (No such file or directory), aborting
02-18 05:46:39.070        99-99/? A/libc﹕ Fatal signal 6 (SIGABRT) at 0x00000063 (code=-6), thread 99 (surfaceflinger)
02-18 05:46:43.430      137-137/? E/cutils﹕ Failed to read /data/.layout_version: No such file or directory
02-18 05:46:43.430      137-137/? E/installd﹕ Could not create directories; exiting.
02-18 05:46:43.710      138-138/? E/keystore﹕ chdir: /data/misc/keystore: No such file or directory
02-18 05:46:44.160      134-134/? E/SurfaceFlinger﹕ hwcomposer module not found
02-18 05:46:44.160      134-134/? E/SurfaceFlinger﹕ ERROR: failed to open framebuffer (No such file or directory), aborting
02-18 05:46:44.170      134-134/? A/libc﹕ Fatal signal 6 (SIGABRT) at 0x00000086 (code=-6), thread 134 (surfaceflinger)
02-18 05:46:48.530      150-150/? E/cutils﹕ Failed to read /data/.layout_version: No such file or directory
02-18 05:46:48.530      150-150/? E/installd﹕ Could not create directories; exiting.
02-18 05:46:48.670      151-151/? E/keystore﹕ chdir: /data/misc/keystore: No such file or directory
02-18 05:46:49.260      147-147/? E/SurfaceFlinger﹕ hwcomposer module not found
02-18 05:46:49.260      147-147/? E/SurfaceFlinger﹕ ERROR: failed to open framebuffer (No such file or directory), aborting
02-18 05:46:49.260      147-147/? A/libc﹕ Fatal signal 6 (SIGABRT) at 0x00000093 (code=-6), thread 147 (surfaceflinger)

Wie kann ich es reparieren? Mein Gerät läuft nicht Danke im Voraus. 

16
malcoauri

Aktivieren Sie beim Erstellen des Emulators die Option "Use Host GPU" (Host-GPU verwenden) unten und versuchen Sie es mit .. Für diejenigen, die die "Use Host GPU" nicht finden können, lesen Sie bitte die folgenden Optionen: "Snapshot" und "Use Host GPU" fehlt in den AVD-Einstellungen

54
Sushil

Scheint wie ein Problem mit hoher Auflösung https://code.google.com/p/Android/issues/detail?id=76948

versuchen Sie, die Auflösung zu verringern

2
Rahul Tiwari

Ich möchte nur hinzufügen 

Aktivieren Sie beim Erstellen des Emulators die Option "Host-GPU verwenden" unten und versuchen Sie es.

Stellen Sie sicher, dass Ihr TARGET API Ihres Projekts mit Ihrer EMULATOR's-Version übereinstimmt. 

Wenn Ihr Projekt 4.4.2 anvisiert, stellen Sie sicher, dass Ihr Emulator auf 4.4.2 eingestellt ist :) 

0
James111