web-dev-qa-db-de.com

FAILURE: Fehler beim Erstellen mit Ausnahme

Aufgaben ausführen: [: app: assembleDebug]

WARNUNG: Die Option 'Android.enableAapt2' ist veraltet und sollte nicht .__ sein. mehr verwendet werden. Verwenden Sie "Android.enableAapt2 = true", um diese Datei zu entfernen Warnung. Sie wird Ende 2018 entfernt.: App: preBuild UP-TO-DATE: app: preDebugBuild UP-TO-DATE: app: compileDebugAidl UP-TO-DATE: app: compileDebugRenderscript UP-TO-DATE : app: checkDebugManifest UP-TO-DATE: app: generateDebugBuildConfig UP-TO-DATE: app: prepareLintJar UP-TO-DATE : app: mainApkListPersistenceDebug UP-TO-DATE : app: generateDebugResValues ​​UP-TO-DATE: app: generateDebugResources UP-TO-DATE: app: mergeDebugResources FAILED

FEHLER: Die Erstellung ist mit einer Ausnahme fehlgeschlagen.

  • Was ist schiefgegangen: Ausführung fehlgeschlagen für Task ': app: mergeDebugResources'.

    Java.util.concurrent.ExecutionException: Java.util.concurrent.ExecutionException: com.Android.builder.internal.aapt.v2.Aapt2Exception: AAPT-Fehler: Überprüfen Sie die Protokolle auf Details

  • Versuchen Sie: Führen Sie die Option mit der Option --stacktrace aus, um die Stack-Ablaufverfolgung abzurufen. Führen Sie die Option --info oder --debug aus, um weitere Protokollausgaben zu erhalten. Führen Sie mit --scan aus, um vollständige Einblicke zu erhalten.

  • Weitere Hilfe erhalten Sie unter https://help.gradle.org

BUILD FAILED in 13s 9 umsetzbare Aufgaben: 1 ausgeführt, 8 aktuell

8
royalapp

Ändern Sie in gradle.properties Android.enableAapt2=false in true.

21
Luvnish Monga

Sie können tatsächlich Probleme in den Ressourcen haben, diese werden jedoch nicht angezeigt, wenn Sie dieses Problem nicht zuerst beheben: 

Die Option 'Android.enableAapt2' ist veraltet und sollte nicht verwendet werden nicht mehr. Verwenden Sie "Android.enableAapt2 = true", um diese Warnung zu entfernen. Es wird Ende 2018 entfernt.

ersetzen Sie in Ihrer gradle.properties-Datei, die sich im Stammverzeichnis des Projekts befindet, Folgendes: 

Android.enableAapt2 

mit: 

Android.enableAapt2 = true
3
Elenasys

in der Datei gradle.properties, die sich im Stammverzeichnis des Projekts befindet,

Ich habe gerade diese Zeile kommentiert, funktioniert jetzt einwandfrei

Android.enableAapt2 = true

0
anwar alam

Aktualisieren Sie Ihr Gradle-Plugin. Fehler behoben.

0
Mwongera