web-dev-qa-db-de.com

'Keine aktiven kompatiblen AVDs oder Geräte gefunden

Ich bin neu in Eclipse ADT und habe versucht, eine App auf meinem Tablet (einem Samsung Galaxy Note 10.1) auszuführen. Es tritt jedoch der folgende Fehler auf:

[2013-12-26 12:37:41 - SDK_Example] ------------------------------

[2013-12-26 12:37:41 - SDK_Example] Android Launch!

[2013-12-26 12:37:41 - SDK_Example] adb is running normally.

[2013-12-26 12:37:41 - SDK_Example] Performing com.metaio.Example.MainActivity activity launch

[2013-12-26 12:37:41 - SDK_Example] No active compatible AVD's or devices found. Relaunch this configuration after connecting a device or starting an AVD.

Kann mir jemand sagen, warum mein Gerät nicht gefunden wird?

9
user3135716

Anscheinend wird Ihr Gerät von der ADB nicht erkannt.

Überprüfen Sie, ob Sie USB-Debugging aktiviert haben in Ihrem Tablet oder nicht. Manchmal funktioniert es auch, wenn Sie das Gerät trennen und erneut anschließen. Bedenken Sie auch, dass die API-Ebene Ihrer Anwendung von Ihrem Gerät unterstützt werden sollte.

4
Swayam

Wenn Sie den Emulator verwenden, schließen Sie ihn.
Wählen Sie in Eclipse Ausführen> Konfigurationen ausführen> Ziel> Immer zur Auswahl des Geräts auffordern> Ausführen .
Wählen Sie nun ein Gerät aus der Liste oder starten Sie einen neuen Emulator. Wenn Sie das Projekt das nächste Mal ausführen, sollte es funktionieren.

4
vovahost

Der Fehler zeigt, dass die API-Ebene, für die Ihre Anwendung den kompatiblen Emulator für diese API-Ebene hat, nicht vorhanden ist. Sie müssen den Emulator erstellen, der mit der API-Ebene Ihrer Anwendung kompatibel ist.

ODER

Wenn Ihr Emulator bereits gestartet ist, müssen Sie den ADB zurücksetzen, um den Emulator verfügbar zu machen. Gehe zu DDMS > In Device tab > Select Down arrow> Select Reset adb option.

Schauen Sie sich das Bild an enter image description here

4
GrIsHu

Diese Fehlermeldung wird angezeigt, wenn im SDK keine kompatible Android-API gefunden wird. Versuchen Sie, Ihre Eclipse mit der entsprechenden API zu aktualisieren. Um Ihre API zu aktualisieren, gehen Sie zu Fenster -> Android SDK Manager. Wählen Sie dann die gewünschte API-Version aus dem Android SDK Manager-Fenster. Klicken Sie abschließend auf die Schaltfläche Pakete installieren. Nachdem die Installation der erforderlichen Pakete abgeschlossen ist, erstellen Sie eine neue AVD für Ihr Projekt und führen Sie Ihr Projekt aus.

2
BABU K

Sie müssen einen Emulator erstellen oder ein Gerät verwenden, das mit dem API-Ziel kompatibel ist. das Gerät oder der Emulator sollte eine Android-Version haben, die mit Ihrem Projekt kompatibel ist.

1
M D

Ich hatte das gleiche problem Ich hatte USB-Debugging-Set und Eclipse lief die App gut und dann hörte es eines Tages auf. Mithilfe anderer Kommentare hier habe ich festgestellt, dass mein Telefon als Massenspeichergerät eingerichtet werden musste, sonst würde es nicht funktionieren. Sobald ich es von der Kamera oder einer anderen Einstellung zum Massenspeicher geändert habe, hat es funktioniert. Ich muss mit der USB-Einstellung gespielt und sie geändert haben. Das Handbuch erwähnte nicht, dass Massenspeicher erforderlich war.

0

Versuchen Sie in androidmanifest.xml, die Version ab API-Level 8 zu unterstützen

<uses-sdk
    Android:minSdkVersion="8"
    Android:targetSdkVersion="19" />

und sogar versuchen, nicht in der Lage USB-Debugging in Ihrem Handy ..

Vorher sollte Mobile Sync im System installiert sein ...

sobald Sie versuchen, den Code im Projekt zu bearbeiten und sogar zu versuchen, das Projekt zu bereinigen und auszuführen.

0
vinay Maneti