web-dev-qa-db-de.com

Symbol 'RequestQueue' kann nicht aufgelöst werden

Ich bin neu im Android-Studio und in der Volleybibliothek.

Ich habe die volley-Bibliothek von GitHub hinzugefügt und dann diese Zeile hinzugefügt, um die gradle-Datei zu erstellen: compile 'com.Android.support:appcompat-v7:23.0.1'

Und jetzt versuche ich ein paar Tutorials über Anfrage und Antwort von API, aber aus irgendeinem Grund kann ich RequestQueue nicht machen, warum? Ich verwende Android 4.0.3 IceCreamSandwish

Vielen Dank

9
Guest012393

fügen Sie Folgendes zu Ihrer build.gradle -Datei hinzu 

compile 'com.mcxiaoke.volley:library:1.0.19'

wenn das Problem weiterhin besteht, probieren Sie dieses Tutorial aus, um alle Ihre Zweifel zu beseitigen.

Volley zum Android-Projekt hinzufügen

10
CodingRat

Fügen Sie diesen Volley-Repo-Klon zu Ihren Abstufungen hinzu:

compile 'com.mcxiaoke.volley:library:1.0.19'

https://github.com/mcxiaoke/Android-volley

3
headsvk

Fügen Sie die Volley-Bibliothek als Abhängigkeit in der Modul-Datei build.gradle hinzu.

dependencies {
    compile 'com.he5ed.lib:volley:Android-cts-5.1_r4'
}

Dies ist ein weiterer Spiegel der Google Volley-Bibliothek https://github.com/he5ed/volley

2
Grace Coder

Ich würde es im build.gradle hinzufügen:

compile 'com.mcxiaoke.volley:library:1.0.19'

du hast hinzugefügt 

compile 'com.Android.support:appcompat-v7:23.0.1'

das ist eine völlig andere Sache (eine Rückwärtskompatibilitätsbibliothek für ältere API-Ebenen).

1
sschrass

Google hat es seinen eigenen Dokumentationsseiten und GitHub https://developer.Android.com/training/volley/index.html hinzugefügt.

Die Abhängigkeit kann hinzugefügt werden mit:

dependencies {
    ...
    implementation 'com.Android.volley:volley:1.1.0'
}
0
Aaron Thompson