web-dev-qa-db-de.com

Es wurde keine übereinstimmende Version für [email protected]^1.1.0 gefunden

Abhängigkeiten für das npm-Projekt:

"dependencies": {
    "angular-chart.js": "1.1.0",
    "angular-cookies": "1.5.7",
    "angular-ui-bootstrap": "2.4.0",
    "angular-ui-grid": "4.0.5",
    "checklist-model": "0.10.0",
    "json-schema": "0.2.2"
  }

Und npm install hört auf, mit dem folgenden Fehler zu arbeiten:

npm ERR! code ETARGET
npm ERR! notarget No matching version found for [email protected]^1.1.0
npm ERR! notarget In most cases you or one of your dependencies are requesting
npm ERR! notarget a package version that doesn't exist.
npm ERR! notarget 
npm ERR! notarget It was specified as a dependency of 'cosmiconfig'
npm ERR! notarget 

Wie man es repariert?

9
Nikita

Es gibt einen offenen Vorfall mit der npm-Registry.

Details zum Vorfall:

Mehrere Pakete, einschließlich "required-from-string", sind derzeit Nicht verfügbar. Wir sind uns des Problems bewusst und arbeiten daran, die betroffenen Benutzer und Pakete wiederherzustellen. Versuchen Sie nicht, Pakete erneut zu veröffentlichen, da dies den Fortschritt bei der Wiederherstellung behindern wird. 6. Januar, 19:45 UTC

13
thelostspore

 enter image description here

Einige Probleme mit der NPM-Registry. Einige der Pakete wurden gelöscht. Sie werden wiederhergestellt ... es wird in Kürze verfügbar sein

Temporäre Lösung holt das Paket aus bereits laufenden Projekten/älteren Projekten

forRequest-from-stringpackage kann den folgenden Link verwenden npm install https://github.com/floatdrop/require-from-string/tarball/ v1.1.0

3
Lijo

ng dient jetzt zu Problemen Versionen von @ angle/compiler-cli und TypeScript konnten nicht ermittelt werden. Der häufigste Grund dafür ist eine fehlerhafte npm-Installation.

Stellen Sie sicher, dass package.json in DevDependencies sowohl @ angle/compiler-cli als auch TypeScript enthält. Löschen Sie dann node_modules und package-lock.json (falls vorhanden) und führen Sie Erneut aus .

1
user3566250