web-dev-qa-db-de.com

wie man Bower zwingt, eine bestimmte Version der Abhängigkeit zu installieren

Angenommen, eine bower.json - Datei, in der Abhängigkeiten ähnlich sind

"dependencies": {
    "angular": "~1.5.x",
    "angular-routing": "*",
    "ngDialog": "*",
    "requirejs": "*"
}

da angular-routing eine andere Version von angular erfordert (sagen Sie 1.2.x), fordert mich Bower auf, eine Version auszuwählen.

Wie kann ich bower zwingen, angular ~1.5.x Automatisch zu installieren?

25
Reyraa

Ich fand die Antwort heraus. Ich teile für andere:

Wenn ich die Abhängigkeit mit meiner Lieblingsversion zu resolutions in bower.json Hinzufüge, installiert Bower sie automatisch. Hier ist mein aktualisierter bower.json:

"dependencies": {
  "angular": "~1.5.x",
  "angular-routing": "*",
  "ngDialog": "*",
  "requirejs": "*"
},
"resolutions": {
  "angular": "~1.5.x"
}

Weitere Informationen hier .

Update:
Wie Mattliu in den Kommentaren erwähnt hat, kann mit ! Geantwortet werden, wenn eine Bibliothek nach einer anderen Version einer bereits installierten Abhängigkeit fragt. Auf diese Weise behalten Sie die vorhandene Version bei und npm erstellt resolution config automatisch.

33
Reyraa

Wenn Sie JQuery 2.1.4 strikt installieren und zu Ihren bower.json-Abhängigkeiten hinzufügen möchten, würden Sie folgendermaßen vorgehen

bower install jQuery#2.1.4 --save
26
Arnaud Bouchot
  • Sie müssen die Version in bower.json angeben.
  • Beachten Sie, dass die Verwendung einer Tilde wird automatisch in eine neuere Nebenversion aufgelöst
  • Wenn Sie also ~ 1.5.x angeben, wird 1.5.1 gezogen, wenn es existiert
  • Entfernen Sie zum Angeben einer genauen Version die Tilde, z. "1.5.1" angeben
3
Chris Halcrow