web-dev-qa-db-de.com

Die Openstack-Installation schlägt aufgrund einer falsch angegebenen Ubuntu-Version fehl

Ich habe dieses Tutorial von YouTube für Openstack auf Ubuntu (mit Autopilot) verfolgt: https://www.youtube.com/watch?v=64HXwmgOQKw

Ich habe ubuntu 16.04 verwendet, alles hat funktioniert, bis ich "Sudo openstack-install" eingetippt habe. Die Antwort der CLI war, dass der Befehl nicht gefunden wurde. Ich hatte zuvor versucht, openstack mit den gleichen Schritten zu installieren, und habe in diesem Punkt nicht das gleiche Ergebnis erzielt. Ich habe versucht, die gesamte Installation einschließlich einer Neuinstallation des Ubuntu-Servers, aber immer noch das gleiche Ergebnis.

Ich habe im Internet gesucht und die folgende Antwort erhalten: Ist Autopilot Openstack 16.04 verfügbar? .

Bei der Ausgabe von conjure-up openstack gab die CLI den folgenden Fehler aus:

enter image description here

Ich habe jeden Ort überprüft, an dem das "vertrauenswürdig" sein könnte, aber was ich finde, war alles in Ordnung. Ich habe auch die environ.yaml-Datei auf JUJU überprüft, die auf die richtige Distributionsversion eingestellt war.

Frage:

1.) Warum wird der Befehl nicht gefunden? Wie kann ich das lösen?

2.) Warum erhalte ich diesen Fehler als vertrauenswürdig, wenn ich "zaubern" benutze? Wie kann ich das lösen?

P.S. Die erste Frage wäre meine Vorliebe für das Lösen gewesen, da dies eher die "normale" Art der Installation wäre.

P.S.S.

Ubuntu-Version: Ubuntu 16.04.1 LTS (Xenial)

MAAS-Version: 2.0.0 ~ rc2 + bzr5156-0ubuntu1 ~ 16.04.2

JUJU-Version: 2.0 ~ beta12-0ubuntu1.16.04.1

Befehle wie "Sudo apt-get update" und "Sudo apt-get upgrade" wurden mehrfach ausgeführt. Auch der Neustart des Servers wurde einige Male durchgeführt.

Update 1:

Ich habe die Antwort von @ gangstaluv versucht, aber ich habe den Fehler erhalten: Version 0.18 for distro-info-data was not found. Ich habe versucht, distro-info-data neu zu installieren, aber auch dort kein Glück. Ich habe das (0.18) -Paket vom Launchpad heruntergeladen und installiert, aber bei der Ausgabe des Befehls distro-info --lts trusty wurde ein Fehler des Befehls nicht gefunden. Ich habe das Paket überprüft, indem ich dpkg -s distro-info-data ausgegeben habe, und bin zurückgekommen, dass das Paket existiert und die Version 0.18 ist. Ich hoffe das macht das Problem so klar wie möglich :)

Update 2:

Ich finde die Lösung! Zuerst habe ich das MAAS-Paket auf die Version "2.0.0 + bzr5189-0ubuntu1" aktualisiert (offiziell für 16.10 gedacht, aber es funktioniert). Dann habe ich die Lösung von ognjen verwendet. Die Kombination dieser 2 führte dazu, dass die Installation zu diesem Zeitpunkt keinen Fehler mehr ergab.

6
user3892683

Wenn Sie MAAS ausführen, stellte ich in meinem Fall fest, dass ich das kurzlebige Image als 14.04 ausführen und das Image als 16.04 bereitstellen musste. Laden Sie also unter Bilder sowohl 14.04LTS als auch 16.04LTS herunter. Stellen Sie in den Einstellungen sicher, dass in den Abschnitten Commissioning (14.04LTS) und Deploy (Bereitstellen) der Wert 16.04LTS angegeben ist.

3
ognjen

Um Ihre erste Frage zu beantworten, haben wir im 16.04 die Möglichkeit, 'Sudo openstack-install' zu machen, zugunsten von 'openstack zaubern' aufgegeben, da wir neben openstack weitere Installationen behandeln wollten.

Die Frage zu dem Fehler könnte mit https://bugs.launchpad.net/maas/+bug/1537095 zusammenhängen (eine Problemumgehung wird am Ende des Fehlers vorgeschlagen) oder Sie haben nicht geklickt Aktivieren Sie das Kontrollkästchen 14.04 in MAAS, um das Image zu synchronisieren. Die Problemumgehung lautet:

Problemumgehung für WfM: Downgrade von Distro-Info-Daten auf Pre-Xenial mit:

apt-get install distro-info-data=0.18

, so dass diese vertrauenswürdige Installation stattdessen gibt:

  $ distro-info --lts trusty

Nur FTR/FAOD unten funktioniert jetzt wie erwartet:

  juju bootstrap --upload-tools --series trusty

Sie können jederzeit http://conjure-up.io besuchen, um die neuesten Informationen zur Installation und Ausführung von conjure-up zu erhalten.

2
battlemidget