web-dev-qa-db-de.com

Die Version von CocoaPods, die zum Generieren der Sperrdatei (1.5.3) verwendet wird, ist höher als die Version der aktuellen ausführbaren Datei (1.5.2).

auf $pod install es gibt eine Warnung & schlägt fehl

Die Version von CocoaPods, die zum Generieren der Sperrdatei (1.5.3) verwendet wird, ist höher als die Version der aktuellen ausführbaren Datei (1.5.2)

Was will es damit sagen?

macOs: 10.11.6 osx el capitan

meine Pod-Version ist: 1.5. 3

Was bedeutet "Aktuelle ausführbare Datei" (1.5. 2 )?

und

wie aktualisiere ich es?

11
vijay

Der Fehler, den Sie erhalten, liegt daran, dass Ihr podfile.lock mit einer älteren Version von Cocoapods erstellt wurde. Alles was Sie tun müssen, ist Ihre podfile.lock-Datei zu löschen und pod install. Dadurch wird eine neue podfile.lock mit Ihren aktuellen Abhängigkeiten erstellt. Beachten Sie, dass es nicht zu lange dauern sollte, da Ihre Dateien bereits heruntergeladen sein sollten. Sie müssen lediglich in dieser Datei verlinkt werden.

24
Jstngoulet

2 Lösung

  1. gelöscht ios/podfile.lock und erneut $pod install

ODER

  1. OS UPDATE

    2.1 Mac wurde auf High Sierra oder höher aktualisiert

    2.2 xcode aktualisieren

    2.3 dann update pod $ Sudo gem install cocoapods

    2.4 dann $cd ios

    2.5 dann $pod install

    2.6 $react-native start-ios

7
vijay