web-dev-qa-db-de.com

Pod-Datei wird nicht initialisiert?

Wenn ich versuche, die Pod-Datei zur Verwendung von cocoapods über das Terminal zu initialisieren, wird mir dieser Fehler angezeigt. Wie man es repariert.

/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.2.0/lib/cocoapods/command.rb:128:in `verify_minimum_git_version!': [!] You need at least git version 1.8.5 to use CocoaPods (Pod::Informative)
17

Ich stelle das gleiche Problem fest und löse es mit dem folgenden Befehl:

Sudo xcode-select --switch /Applications/Xcode.app 

Wie die Fehlermeldung in terminal zeigt, geht etwas mit meiner git schief. Und es hat mit dem Befehlszeilentool zu tun.

51
Guohua Cheng

Beim Versuch, Pakete mit Cocoapods zu installieren, gab es ein Problem. Ich habe versucht, "Sudo xcode-select --switch /Applications/Xcode.app" immer noch einen falschen Pfadfehler zu erhalten

Um das zu beheben

Ich habe Xcode geöffnet.

Preferences
Locations
Selected the Command Lin Tools: Xcode 9.0

Beim Installieren von Paketen mit Cocoapoden bekomme ich jetzt keine Fehler mehr.

32
Joyal Clifford

Sie müssen die Version des Befehlszeilentools in Xcode einstellen:

Sie können das neueste Befehlszeilentool von Apple Download Portal herunterladen, wenn Sie Apple Developer Account/ID bezahlt haben.


Hier sind das aktuelle Beta-Programm und das stabile Xcode-Tool sowie der unterstützende Download-Link für das Befehlszeilen-Tool. (Stellen Sie sicher, dass Sie mit einem Premium-Entwicklerkonto beim Apple-Entwicklerkonto angemeldet sind, um auf diese Links zuzugreifen.)

Xcode 10

Xcode 9

Wenn Sie das neueste Befehlszeilentool in Ihrem System installiert haben, legen Sie es im Xcode-Menü fest.

(Xcode-Menüelemente) Xcode ▶ Voreinstellungen ▶ Position ▶ Befehlszeilenwerkzeug ▶ Auswahl des entsprechenden Befehlszeilenwerkzeugs

 enter image description here

2
Krunal

Wenn Sie Ihr MAC vom App Store aus aktualisiert haben, müssen Sie Folgendes ausführen: xcode-select --install

Als ich git --version ausgeführt habe, bevor der obige Befehl ausgeführt wurde, wurde git überhaupt nicht gefunden. Dieser Fehler wurde angezeigt: Xcrun fehlt unter:/Library/Developer/CommandLineTools/usr/bin/xcrun. Ich vermute, als ich meine Maschine aufgerüstet habe, habe ich irgendwie den Idioten verloren. Trotzdem funktionierte der obige Befehl. 

Ich lief dann git --version und es wurde die installierte git-Version angezeigt.

Reference:http://tips.tutorialhorizon.com/2015/10/01/xcrun-error-invalid-active-developer-path-library-developer-commandline-toolss-missing-xcrun/

2
Sandy D.

Nach der Installation von OS Mojave und der Installation neuer Xcode-Tools musste ich die Tools nur noch einmal überprüfen:

Xcode> Voreinstellungen> Positionen> Befehlszeilentools = Xcode 10.0

1
FBC

Ich folgte dem

Nach der Installation von Befehlszeilentools schloss ich es und öffnete das Terminal erneut. Als ich nun die Version git --version überprüfte, gab es die Updateversion 2.10.0 und dann lief ich andere Befehle für cocoapod .

Jetzt funktioniert es.

0
Waaheeda

Hey das könnte dir helfen !!! Ich bin diesem Link gefolgt 

https://stackoverflow.com/a/16664135/7905401

Nachdem ich Befehlszeilentools installiert hatte, schloss ich es und öffnete das Terminal jetzt, als ich Version git --version überprüfte. Es gab mir Update-Version 2.10.0. Dann lief ich andere Befehle für cocoapod !! es funktioniert!!!!!!!!! yeeeii !!!!

0
Waaheeda