web-dev-qa-db-de.com

React Native-Ios-Build ist auf reaktativen Run-Ios nicht erfolgreich

diesen Fehler bekommen

** BUILD FAILED **

Die folgenden Buildbefehle sind fehlgeschlagen: CompileC /Users/karthikn/AwesomeProject/ios/build/Build/Intermediates/React.build/Debug-iphonesimulator/React.build/Objects-normal/x86_64/RCTTabBarItem.o Views/RCTTabBarItem.m normal x86_64 .compilers.llvm.clang.1_0.compiler (1 Fehler)

Installieren von build/build/Products/Debug-iphonesimulator/AwesomeProject.app Bei der Verarbeitung des Befehls ist ein Fehler aufgetreten (Domäne = NSPOSIXErrorDomain, Code = 2): Die angeforderte Anwendung konnte nicht installiert werden Ein Anwendungspaket wurde unter dem angegebenen Pfad nicht gefunden. Geben Sie einen gültigen Pfad zum gewünschten Anwendungspaket an. Print: Eintrag ": CFBundleIdentifier" ist nicht vorhanden

Befehl fehlgeschlagen:/usr/libexec/PlistBuddy -c Print: CFBundleIdentifier build/Build/Products/Debug-iphonesimulator/AwesomeProject.app/Info.plist Print: Eintrag ": CFBundleIdentifier" ist nicht vorhanden

10
furball514

Bei Xcode 8.2 tritt immer noch derselbe Fehler auf. Drei Zeilen unten haben es für mich behoben:) Downgrade reagieren (16.0.0-alpha.12 -> 16.0.0-alpha.6) & reaktionsnativ (0.45.0 -> 0.44.0)
rm -rf node_modules/reag  
npm i [email protected] -S
npm i [email protected] -S
Dann laufe reag-native run-ios

7
thai huynh

Wenn es Ihr erstes Projekt ist, haben Sie möglicherweise dasselbe Problem wie ich: Verwenden Sie NICHT Platz in Ihrem Projektpfad! ???? ???? 

2
Floris M

Versuchen Sie es mit Sudo-reaktivem Run-Ios .__ Das hat mir geholfen

2
Mukesh Kumar

Es ist sehr wahrscheinlich, dass Sie eine veraltete Version von React-Native ausführen und Ihre Vorlage nicht mehr kompatibel ist.

Es gibt Anweisungen , die Möglichkeiten zur Aktualisierung enthalten.

Am einfachsten wäre es, react-native upgrade auszuführen, und Sie werden mit den Dateien aufgefordert, die von reaktativer Natur überschrieben werden sollen. Wenn Sie in allen Eingabeaufforderungen auf Ja klicken, wurde dieses Problem behoben. Wenn Sie jedoch Bedenken haben, dass Änderungen verloren gehen, wird empfohlen, npm install -g react-native-git-upgrade zu installieren und Konflikte nach dem Ausführen von react-native-git-upgrade zusammenzuführen.

1
eric-vandenberg

Ersetzen Sie Boost-C++ - Bibliotheken durch diese Download-Link

/ node_modules/reaktiver Native/Drittanbieter/boost_1_63_0

0
Meghs Dhameliya

Überprüfen Sie dies in Ihrem info.plist-Bundle-Bezeichner 

Oder Fügen Sie diesen Bundle-Bezeichnernamen wie folgt hinzu: 

 enter image description here

0
Lalit kumar

Verwenden Sie KEIN Leerzeichen im Projektpfad. Es hatte mein Problem gelöst.

0
Nimish Patel

Es gibt verschiedene Probleme, die dieses Problem verursachen. Ich werde hier posten, was ich in meinem Fall gelöst habe.

1 - Löschen Sie den Ordner node_modules und die Ordner von Android und ios aus dem Projektstamm:

rm -rf node_modules/ ios/ Android/

2 - Erstellen Sie die Ordner neu:

npm install && react-native upgrade

oder (Wenn Sie im Projekt Garn verwendet haben)

yarn install && react-native upgrade 

3 - Danach einfach den Befehl erneut ausführen:

react-native run-ios 

oder 

react-native run-Android.

Ich hoffe es hat geholfen =)