web-dev-qa-db-de.com

Xcode8.0 Beta 6 - kann nicht vom Gerät lesen

Ich habe gerade Xcode 8.0 von Betaversion 4 auf Betaversion 6 aktualisiert. Ich erhalte die Meldung, dass das Gerät nicht lesen kann, wenn ich die App auf meinem Gerät erstellen möchte. Irgendwelche Ideen was das Problem sein könnte?

56
Michel Arteta

Dies ist der Fehler, wenn die Symbole fehlen . Normalerweise erhalten Sie diese Fehlermeldung, wenn Ihr Gerät eine höhere Version als Xcode hat, beispielsweise iOS 10 vs. Xcode 7.3. In diesem Fall konnte Xcode 8 beta 6 keine iOS 10 beta 6-Symbole vom Gerät kopieren.

  1. Öffnen Sie Devices in Xcode
  2. Wählen sie ihren Gerätetyp . Es sollte eine unerwartete Fehlermeldung angezeigt werden
  3. Delete " ~/Library/Developer/Xcode/iOS DeviceSupport " Verzeichnis
  4. Trennen Sie Ihr Gerät
  5. Starten Sie Ihr Gerät neu
  6. Stecke zurück dein Gerät
  7. Xcode sollte sofort mit dem Kopieren der Symboldateien beginnen 
50
Tibidabo

Ich habe das gleiche Problem gefunden, auch mein iOS> Einstellungen> Entwickler: Es stellte sich als leer heraus. 

Lösung

Auf iOS-Geräten gehen Sie:  

  1. Einstellungen> Allgemein> Zurücksetzen> Netzwerkeinstellungen zurücksetzen 
  2. Das Gerät wird neu gestartet (und Sie verlieren WLAN-Passwörter usw.) 
  3. Starten Sie Xcode 8 (Beta 6) und schließen Sie Ihr Gerät an. 

Wenn dies alleine nicht funktioniert, versuchen Sie es mit 

  1. Trennen Sie Ihr Gerät vom Computer.
  2. Starten Sie Ihren Mac neu 
  3. Laden Sie Xcode 8 beta 6 herunter und legen Sie es im Anwendungsordner ab.
  4. Löschen Sie den Inhalt von:/Benutzer/Benutzer/Bibliothek/Entwickler/Xcode/iOS DeviceSupport.
  5. Führen Sie die obigen Schritte aus, um die Netzwerkeinstellungen auf einem iOS 10-Gerät zurückzusetzen.
  6. Wenn das iOS-Gerät gestartet wird, schließen Sie es an Ihren Mac an. Akzeptieren Sie es als vertrauenswürdiges Gerät
  7. Starten Sie Xcode 8 Beta 6. 

Ich hoffe, dass dies für alle anderen funktioniert. Die obige Liste enthält alle gängigen Korrekturen.

15
Mathias Asberg

Ich habe es geschafft zu arbeiten. Starten Sie Ihr Gerät neu.

Wenn nicht, löschen Sie den Inhalt von/Users/IhrBenutzername/Bibliothek/Entwickler/Xcode/iOS DeviceSupport, schließen Sie ihn erneut an Xcode an und lassen Sie Symboldateien verarbeiten.

15
diegotrevisan
  1. Aktualisieren Sie Xcode auf Xcode 8 Beta 6 
  2. Und Netzwerk auf Ihrem iPhone zurücksetzen (Einstellungen> Allgemein> Zurücksetzen> Netzwerkeinstellungen zurücksetzen).

Das hat bei mir funktioniert. 

12

Ich musste den Schritt "Netzwerk zurücksetzen" für das Telefon nicht ausführen .

3
WimTar

Starten Sie einfach Ihr Gerät neu

Es ist Arbeit für mich ... Vielleicht ist es auch Arbeit für Sie ...

2
Vandit Mehta

Vor ein paar Stunden bekam ich dieselbe Ausgabe. Die folgenden Schritte haben mein Problem behoben.

  1. Starten Sie den Mac neu
  2. Starten Sie das iOS-Gerät neu
  3. Xcode Beta öffnen
  4. Öffnen Sie das Gerätefenster über das Menü "Fenster-> Geräte"
  5. Klicken Sie auf das iPad und warten Sie, bis die Fortschrittsanzeige "Symbole laden" abgeschlossen ist.

Ich brauchte 10 Minuten, um Symbole zu laden, dann erkannte Xcode das Gerät. Und ich musste zweimal iOS-Gerät und einmal Mac neu starten.

Falls nach Schritt 5 ein Fehler angezeigt wird, starten Sie das iOS-Gerät neu (drücken Sie die Home-Taste und die Standby-Taste und warten Sie, bis das Apple-Logo angezeigt wird), und versuchen Sie es in Schritt1.

Meine Konfiguration: Mac (10.11.6), IPad (Build-Version: 10.0_14A5341a), XCode 8.0 beta 6

Hoffe das hilft :)

2
pastmaster

Hatte das gleiche Problem hier. Das Problem wurde behoben, indem das Gerät zurückgesetzt wurde (Ein-/Austaste + Home-Taste) und der Blitz durch einen ursprünglichen ersetzt wurde (anscheinend verwendete ich eine dieser Repliken).

1
radioaktiv

Das Ändern des Entwicklungsziels auf 9 und dann wieder auf 10 hat für mich funktioniert.

Ich habe alle oben genannten Schritte ausprobiert und neu gestartet. Starten Sie sowohl das Telefon als auch mein Mac-Buch neu. Keiner von ihnen funktioniert. Ich ende am Ende Xcode Version 8.1 (8T61a) und es funktioniert iOS 10.1In xcode 8.1 müssen für meine Swift-Dateien einige kleinere Syntaxänderungen vorgenommen werden.

0
Hannah Zhang

meine zwei Cents: Ich kann den gleichen trivial Fix für Version 9.2 (9C40b) und HighSierra/OS 11.2.5 (15D60) bestätigen.

Ich habe den gleichen Fehler erhalten, aber nach dem Neustart von OSX hat es funktioniert.

0
ingconti

Xcode 10 repariert Geräteprobleme für mich neu.

  1. Geräte öffnen: Wählen Sie Menü Xcode> Fenster> Geräte und Simulatoren + ⇧ + 2
  2. Innenfenster "Geräte und Simulatoren":
    1. Wählen Sie Ihr Gerät in der linken Spalte aus
    2. Klicken Sie mit der rechten Maustaste auf das Gerät, um das Listenmenü zu öffnen
    3. Listenmenü auswählen "Unpair Device
    4. Das Gerät zeigt "Vertrauensdialogfeld" an.> Wählen Sie Vertrauenswürdigkeit . Wenn das Dialogfeld nicht angezeigt wird, öffnen Sie auf dem System das System Einstellungen> Entwickler> Vertrauenswürdige Computer löschen
0

Keine der oben genannten Lösungen funktionierte für mich. Es stellt sich heraus, dass es keine Symboldateien zum Herunterladen gibt, wenn Sie mit GM für tvOS 10 arbeiten. Ich habe das Provisioning-Profil für GM entfernt und es hat wie ein Zauber funktioniert.

Hoffe, das war jemandem hilfreich.

0
Nate4436271

Bei XCode 8 Beta 4 war ich mit diesem Problem konfrontiert. Durch die Aktualisierung von XCode auf XCode 8 Beta 6 wurde das Problem behoben.

Ich habe irgendwo gelesen, dass "Einstellungen -> Allgemein -> Zurücksetzen -> Alle Einstellungen zurücksetzen" dieses Problem behebt. Es hat mir nicht geholfen, aber ich hatte es trotzdem getan. Nicht sicher, ob Einstellungen zusammen mit dem Aktualisieren von XCode zurückgesetzt werden müssen.

0
Vinuta