web-dev-qa-db-de.com

Eclipse Mars zeigt Jboss Server nicht an

Hier sind die Dinge, die ich ausprobiert habe

  1. In Eclipse Mars gehen Sie zu Hilfe-> Neue Software installieren 
  2. Klicken Sie auf die Schaltfläche "Hinzufügen" und fügen Sie die URL der Aktualisierungssite ein, die in unserem Fall der Fall ist: Eclipse Mars-Tools für Jboss
  3. Wählen Sie nun das Plugin JBossAS Tools aus und klicken Sie auf "Weiter".

EDIT: -

Ich kann den Jboss-Server in Eclipse mars auch nicht sehen, nachdem ich die obigen Punkte getan habe 

Gehen Sie zum Eclipse-Marktplatz -> Suchen Sie nach Jboss -> Dann aus der Liste Red Hat Jboss Developer Studio (Mars) 9.0-> Bestätigen

Selbst jetzt kann ich den Jboss-Server nicht in der Eclipse-Serverliste sehen, sodass ich meine Anwendung nicht auf dem Jboss-Server ausführen kann.

Kann mir jemand sagen, was das Problem sein kann, warum der Jboss-Server nicht in der Serverliste aufgeführt ist?

enter image description here

EDIT 1: -

enter image description here

6
Subodh Joshi

Sie benötigen Java 8, um Eclipse mit JBoss Tools 4.3.0.Beta1 auszuführen, auch wenn Sie nicht mit dieser Java-Version erstellen und implementieren (dh Sie können Java 6 oder 7 weiterhin erstellen und implementieren). Siehe http://tools.jboss.org/blog/2015-06-23-beta1-for-mars.html#Java-8-to-run-Eclipse-older-runtimes-ok-for-buildsdeployment

11
Xavier Coulon

Laufen Sie mit Java 8? JBoss Tools/Developer Studio Beta auf dem Mars erfordert Java 8.

Sie können es jedoch auch für ältere Versionen von Java verwenden.

1

Dies ist b/c Eclipse mars Installationsprozess durchläuft das Installationsprogramm, das die zu diesem Zeitpunkt installierte JRE auswählt (in meinem Fall war das 1,7), und der JBoss benötigt Java 1.8 für die ordnungsgemäße Installation, wenn Sie Eclipse starten Es zeigt, dass einige Dateien nicht für jBoss installiert werden. Nach der Eclipse-Installation ändert sich die JRE-Umgebung nicht für die JBOSS-Installation. Für mich; Ich habe JDk1.7 von Application/Java/VirtualMachineEmviroment entfernt (JDK1.8 sollte erhalten bleiben) und das Eclipse-Installationsprogramm erneut ausführen. Installieren Sie nun erneut die Jboss-Tools aus dem Eclipse-Markt. Dieses Mal für die neue Serverkonfiguration wird es den Jboss-Community-Ordner geben ...

0

Ich hatte dasselbe Problem, ich habe es gelöst, indem ich Folgendes getan habe

Sie können Laufzeiten in Eclipse installieren, indem Sie Fenster → Voreinstellungen und dann Server → Laufzeitumgebungen aus den links verfügbaren Kategorien auswählen.

Danach erscheinen jboss in der Serveransicht

0
Adrian