web-dev-qa-db-de.com

Fehler beim Installieren des Plugins

Ich versuche ein Plugin in Eclipse Luna zu installieren. Ich habe Papyrus installiert und versuche, SWT Designer zu installieren, aber bevor der Download/die Installation abgeschlossen ist, erhalte ich eine Fehlermeldung:

An error occurred during the
org.Eclipse.equinox.internal.p2.engine.phases.CheckTrust phase.
session context was:(profile=epp.package.standard,
phase=org.Eclipse.equinox.internal.p2.engine.phases.CheckTrust,
operand=, action=). Error reading signed content. error in opening Zip
file

Nach diesem Fehler kann ich nichts installieren und der Installationsmanager funktioniert nicht mehr und zeigt mir immer den gleichen Fehler. Nur auf eine Weise lösche ich das aktuelle Eclipse-Verzeichnis und extrahiere es erneut.

Dieses Mal installiere ich Papyrus, SWT Designer und einige andere, aber ich bekomme die Fehlermeldung, dass ein anderes Plugin erneut installiert wird. Dies ist falsch, wenn bei der Installation eines Plugins ein Fehler auftritt, wenn Eclipse und das andere Plugin erneut installiert werden.

Ist das ein Fehler oder ein Problem?

55
user3855547

Ok schließlich finde ich die Lösung für dieses Problem. Ich weiß nicht, warum Eclipse mir diesen Fehler anzeigt und ich weiß nicht, ob dies die beste Lösung ist, aber ich löse mein Problem mit der Datei artifacts.xml in Eclipse-Stammverzeichnis Nach dem Löschen dieser Datei versuchen Sie, das Plugin erneut zu installieren, diesmal jedoch nach ein paar Sekunden, bis alles fertig ist und einwandfrei funktioniert

UPDATE: Wenn der Fehler erneut auftritt, gehen Sie in das Eclipse-Stammverzeichnis und suchen Sie nach "artifacts.xml" und löschen Sie alle Dateien im Ergebnis;).

130
user3855547
  1. Entfernen Sie den artifacts.xml aus dem Ordner.

  2. Bewahren Sie eine Kopie an einem anderen Ort auf (vorzugsweise externe Geräte wie Pendrive, Festplatten usw.).

  3. Starten Sie Eclipse neu. 

  4. Installieren Sie das Software-Plugin, das Sie installieren möchten (es wird erneut um Erlaubnis gefragt).

  5. Fügen Sie nach der Installation die artifacts.xml-Datei wieder in den Eclipse-Ordner ein.

  6. Starten Sie Eclipse neu und legen Sie den SDK-Speicherort fest.

  7. Code zu Tode !!! ; p

20
Akshay

Führen Sie Eclipse als Administrator aus und versuchen Sie dann, das Plugin erneut mithilfe von Hilfe -> Neue Software installieren zu installieren. es hat für mich funktioniert

7
The Prince

Ich habe E4 RCP Patch (bugzillas 445122) installiert (Neue Software installieren -> Eclipse 4.4.1 Patches für Fehler 445122) und das hat mir geholfen.

2
Taras B

Dieses Problem ist mir beim Aktualisieren der internen Software von Eclipse aufgefallen. Ich entdeckte, dass die JAR-Datei org.Eclipse.epp.mpc.help.ui_1.5.2.v20161004-1655.jar (gefunden in den Fehlerdetails) im Eclipse-Plugins-Verzeichnis beschädigt war (7-Zip konnte den Inhalt nicht prüfen) . Ich habe diese Datei erneut heruntergeladen und manuell durch eine von ihrer Site heruntergeladene Datei ersetzt. Anschließend konnte ich die Software ohne Probleme installieren. Hoffe das hilft :)

(Wenn es sich um eine andere JAR-Datei für Sie handelte, können Sie auf diese Seite auf "show directory contents" klicken und die benötigte herunterladen.)

1
Nathan Meyer

Vor kurzem hatte ich dieses Problem und ein paar Workarounds, um die Dinge richtig zu machen, 

Drag & Drop von der offiziellen Seite. Normalerweise startet Eclipse nach dem Download neu. Ein Popup-Fenster fordert Sie auf, die svn-Connectors aus der Liste auszuwählen. aber das ist mir nicht passiert.

  1. Installiere das svn Plugin. (Per Drag & Drop oder Installation neuer oder beliebiger Software)

  2. Nach diesem goto window->preferences->Team->svn

  3. wählen Sie Connector Tab und klicken Sie auf Get connectors Button. Die Eingabeaufforderung erscheint. Wählen Sie eine beliebige connector aus, um den Vorgang abzuschließen (ich verwende NativeHL 1.8).

0
Aravindh Gopi

Ich habe dieses Problem durch die Bearbeitung der artifacts.xml gelöst.

  1. Schließen Sie Eclipse.
  2. Bearbeiten Sie die Artifacts.xml.
  3. Suchen und löschen Sie frühere Einträge, die sich auf das Plugin beziehen, das Sie Installieren möchten.
  4. Speichern Sie artifacts.xml.

Danach sollten Sie Eclipse normal starten und das Plugin installieren können.

0
Kent

Ich habe viele Lösungen von hier aus ausprobiert, darunter die mit Entfernen von artifacts.xml und habe versucht, mit Als Administrator ausführen mit der Option "Hilfe" zu installieren. "Neue Software installieren" Nichts davon hat bei mir funktioniert.

Dann habe ich auf die neueste Version von JDK aktualisiert und es hat perfekt funktioniert. Ich hoffe, dies hilft Ihnen.

Vielen Dank. Vijay P.

0
Vijay P.