web-dev-qa-db-de.com

Fehler: Modul 'Babel-Loader' kann nicht aufgelöst werden

Ich versuche, webpack mit meinem Postinstall-Skript in package.json auszuführen, wenn ich auf Heroku schiebe, aber ich erhalte die folgende Fehlermeldung.

ERROR in Entry module not found: Error: Cannot resolve module 'babel-loader' in /tmp/build_6cb4b10367d9382367ab72f2e2f33118

Wenn ich den Befehl lokal ausführe, erhalte ich keine Probleme. Im Folgenden finden Sie meine Webpack-Konfiguration. Ich habe versucht, mithilfe von resolLoader das Problem zu beheben, jedoch ohne Erfolg.

var path = require('path');
var webpack = require('webpack');

var config = {
  entry: path.resolve(__dirname, './app/main.js'),
  output: {
    path: path.resolve(__dirname, 'dist'),
    filename: 'bundle.js'
  },
  module: {
    loaders: [
      {
        test: /\.js$/,
        exclude: /node_modules/,
        loader: 'babel-loader'
      },
      {
        test: /\.less$/,
        loader: 'style!css!less'
      }]
  },
  resolve: {
    extensions: ['', '.js', '.jsx', '.less'],
    modulesDirectories: [
      'node_modules'
    ]
  },
  resolveLoader: {
    root: path.resolve(__dirname, 'node_modules')
  },
  plugins: [
    new webpack.optimize.UglifyJsPlugin({minimize: true})
  ]
};

module.exports = config;

Irgendwelche Vorschläge? Vielen Dank

16
Geraint

Ich habe herausgefunden warum. Ich hatte kein babel oder babel-core in meinem package.json. Fügen Sie sie hinzu, um den Fehler zu beheben.

  "devDependencies": {
    "babel": "^5.8.23",
    "babel-core": "^5.0.0",
    "babel-loader": "^5.3.2"
}
34
Geraint

In meinem Fall hatte ich den Loader während der Installation falsch geschrieben 

babel-loader  

NICHT

babellader

9
Prakash Tiwari

In meinem Fall habe ich den Befehl ausprobiert:

$ npm install babel-loader --save

der Rest wurde basierend auf der Erinnerung von der Konsole behoben und das Problem behoben:

"Fehler im Einstiegsmodul nicht gefunden: Fehler: 'babel-loader' kann nicht aufgelöst werden"

1
Hailin Tan

Ich benutze Garn und Webpacker für ein Rails + Reaction Project.

Ich weiß, dass nicht jeder alle Abhängigkeiten aktualisieren kann, ohne die Dinge zu beschädigen, aber für mich ist das Hinzufügen von running yarn upgrade Fehler behoben.

Das war mit nur @babel/core in meiner dependencies Konfiguration, seit babel-loader ist als Abhängigkeit von webpacker enthalten.

0
lucas

Ich hatte meine in devDependencies und es hat nicht funktioniert, ich habe sie auf Dependencies umgestellt und es hat endlich funktioniert!

0
Gio

In einigen Fällen werden bei der Bereitstellung für die Produktion (z. B. mit Rails Webpacker) Dev-Abhängigkeiten nicht geladen. Babel-loader in devDependencies funktioniert also nicht.

Tatsächlich macht es Sinn, dass der Babel-Loader in dependencies und nicht in devDependencies platziert wird, da er im Produktionscode selbst verwendet wird. Die einzigen Pakete, die in devDependencies enthalten sein sollten, sind diejenigen, die in der Entwicklung ausgeführt werden, z. B. Tests und Linters.

0
Robin Daugherty

Ich habe den Ordner yarn.lock und node_modules gelöscht und dann babel-loader in Ihren devDependencies in package.json weggelassen, dann habe ich yarn erneut ausgeführt, und es funktioniert.

0
howdyhyber