web-dev-qa-db-de.com

Reagieren Sie die native Expo, die das variable Selbst nicht finden kann

Ich erhalte plötzlich diesen Fehler beim Erstellen des neuen Projekts in expo. Wenn ich ein Projekt erstelle, wird es perfekt geladen und der Standardbildschirm wird angezeigt. 

Wenn ich versuche, eine Abhängigkeit zu installieren, z. Garn addiert native-Basis es funktioniert nicht mehr und ich kann nicht finden Variable finden und Expo wird gehängt 

Bitte danke im voraus 

10
Kedar Dave

Für Benutzer, die ein neues Projekt mit expo-cli oder XDE erstellen, wird nach dem ersten "Garn" oder "npm install" der rote Bildschirm "Variable nicht gefunden" angezeigt. Dies ist wegen des neuen "whatwg-fetch" 3.0.0, das gestern veröffentlicht wurde ( https://www.npmjs.com/package/whatwg-fetch 23). Sie müssen also nur die Abhängigkeit zur vorherigen Version erzwingen: "whatwg-fetch": "^ 2.0.4" Dies bedeutet, dass Sie es in package.json als "Abhängigkeit" eingeben. Manuell, mit "Garne [email protected]" oder mit "npm add [email protected]".

Alles sollte jetzt wie ein Zauber wirken.

Hoffe das hilft, p

Links:

Up: [email protected] fügte [email protected] als Abhängigkeit hinzu. Problem ist weg;)

28
Florian Bonniec

eines ist mir aufgefallen: Aufgrund anderer Abhängigkeiten reichte es mir nicht aus, die neueste Expo-Version zu verwenden. Ich musste auch zu Yarn wechseln (anstelle von npm).

0
Thorsten

die Antwort darauf lautet also 

"Ja, Sie müssen es in package.json einfügen. Manuell mit" garne [email protected] "Oder mit" npm install [email protected] ""

0
Kedar Dave

danach erhalte ich die Fehlermeldung, dass ein unbekanntes Modul "985" erforderlich ist. Wenn Sie sich sicher sind, dass das Modul vorhanden ist, versuchen Sie, Metro Bundler neu zu starten. Sie möchten möglicherweise auch 'garne' oder 'npm install' ausführen. Ich habe beide Dinge getan, aber immer noch den Fehler erhalten. Wer sieht das schon?

edit: gelöst. Alle Dateien geschlossen und das Telefon neu gestartet. Fehler ging weg.

0
irene-hakes