web-dev-qa-db-de.com

Wordpress Rest API

Ich versuche, einen Beitrag aus einer Wordpress-Installation mit der WP REST-API aufzurufen. Ich erhalte immer wieder eine Fehlermeldung und kann nicht herausfinden, warum. Muss ich mich authentifizieren? Auf einer Website wurde angegeben, dass ich mich für eine GET-Anfrage nicht authentifizieren muss. WP REST API: Version 2.0-beta9. Hier ist der Code, den ich benutze:

$(document).ready(function () {

setTimeout(GetPosts, 2000);

function GetPosts() {

     $.ajax({
        url: 'http://easterly.haamap.com/wp-json/posts',
        data: {
            filter: {
            'posts_per_page': 1
            }
        },
        dataType: 'json',
        type: 'GET',
        success: function(data) {
            console.log(data);
        },
        error: function() {
            console.log('error');
        }
    });

}

})
4
The Hawk

Welche Version der REST -API verwenden Sie? Wenn Sie die mit WordPress 4.4 (dh v2) mitgelieferte Version verwenden, müssen Sie Ihre url in http://example.com/wp-json/wp/v2/posts ändern.

Referenz

WP API Version 2-Dokumente

4
Pat J