web-dev-qa-db-de.com

Wie installiere ich Valgrind unter macOS Catalina (10.15) mit Homebrew?

Ich habe versucht, Valgrind mit dem Befehl Brew Install Valgrind zu installieren, und es wird folgende Meldung angezeigt:

"valgrind: Diese Formel wird auf MacOS-Versionen, die neuer als Sierra sind, aufgrund einer Upstream-Inkompatibilität entweder nicht kompiliert oder funktioniert nicht wie erwartet. Fehler: Eine nicht erfüllte Anforderung hat diesen Build nicht bestanden."

Ich habe auch versucht, "valgrind bearbeiten" zu brauen und "sourceware.org/git/valgrind.git" durch "git: //sourceware.org/git/valgrind.git" im Kopfabschnitt des Codes zu ersetzen, und dann auf Iterm geschrieben. " brew install --HEAD valgrind "aber es gibt mir:

Last 15 lines from /Users/m/Library/Logs/Homebrew/valgrind/02.configure:
checking for gcc-ar... no
checking for Perl... /usr/bin/Perl
checking for gdb... /no/gdb/was/found/at/configure/time
checking dependency style of clang... none
checking for diff -u... yes
checking for clang option to accept ISO C99... none needed
checking for a supported version of gcc... ok (clang-11.0.0)
checking build system type... x86_64-pc-darwin
checking Host system type... x86_64-pc-darwin
checking for a supported CPU... ok (x86_64)
checking for a 64-bit only build... yes
checking for a 32-bit only build... no
checking for a supported OS... ok (darwin)
checking for the kernel version... unsupported (19.0.0)
configure: error: Valgrind works on Darwin 10.x, 11.x, 12.x, 13.x, 14.x, 15.x, 16.x and 17.x (Mac OS X 10.6/7/8/9/10/11 and macOS 10.12/13)

READ THIS: https://docs.brew.sh/Troubleshooting
10
Mochi

Ich habe eine Abzweigung von Valgrind gefunden, die unter Mac OS X Catalina funktioniert. Sie finden sie hier https://github.com/sowson/valgrind

0
Dendi Suhubdy