web-dev-qa-db-de.com

npm WARN npm npm unterstützt Node.js v9.1.0 nicht

Ich habe auf den neuesten Knoten v9.1.0 aktualisiert und npm funktioniert jetzt nicht.

npm WARN npm npm unterstützt Node.js v9.1.0 nicht

32
Matt

Es stellt sich heraus, dass die aktuell installierte npm nicht mit der neuen node kompatibel ist und nur schwer aktualisiert werden kann.

Die Lösung besteht darin, npm zu deinstallieren und anschließend node erneut zu installieren, die die korrekte Version von npm enthält.

Hier ist wie:

  1. Deinstallieren Sie npm.

    Mac:
    Sudo npm uninstall -g npm
    
    Windows:
    npm uninstall -g npm
    
  2. Installieren Sie node von https://nodejs.org

46
Matt

Deinstallieren Sie die globale Instanz von npm:

npm uninstall -g npm

Dies führt dazu, dass Ihr System auf die von Knoten 9.1.0 installierte Version von npm zurückgreift und die Warnung verschwindet.

17
Ilyich

Problem mit dem Update auf 5.71 behoben

npm uninstall -g npm

npm i -g [email protected]
11
tomtom

für mich gearbeitet

npm uninstall -g npm

npm i -g [email protected]

Keine manuelle Installation oder Löschung des Cache erforderlich. .__ Führen Sie bei Bedarf mit Administratoranmeldeinformationen aus.

7
Sasha Firsov

Was für mich funktionierte, war, npm und npm cache aus C:\Users\chrisd\AppData\Roaming zu löschen.

Dann lief ich npm i -g [email protected] für die neueste Version von npm für Node 9.x

NPMJS.org hat eine neue Version 11.27.2017 veröffentlicht - npm v5.6.0

(Sie müssen den npm/npm cache möglicherweise nicht löschen, wenn Sie gerade ein Upgrade durchführen, aber ich hatte das bereits getan, bevor Sie die neue Version gefunden haben).

NPMJS Versionshinweise

6
Chris22

Hatte ähnliches Problem in Ubuntu, unten half es zu lösen.

  1. Entfernen Sie vorhandene Versionen von npm und node:

    Sudo apt --auto-remove purge npm
    Sudo apt --auto-remove purge nodejs
    
  2. Knoten neu installieren

4
Alex M

Ich habe die folgende Warnung erhalten, als ich ausgeführt habe, npm install, um package.json für mein Winkelprojekt zu installieren.

npm WARN npm npm unterstützt Node.js v9.1.0 .__ nicht. npm WARN npm Sie sollten wahrscheinlich ein Upgrade auf eine neuere Version des Knotens durchführen. npm WARNUNG npm kann keine Zusagen machen, dass npm mit dieser Version funktioniert. npm WARN npm Unterstützte Versionen von Node.js sind die neueste Version von 4, 6, 7, 8 . npm WARN npm Die neueste Version finden Sie unter https://nodejs.org/ WARNUNG: Sie verwenden wahrscheinlich eine Version von node-tar oder npm, die mit dieser Version von Node.js.ng-080b84bf08dd68e5.lock für ...\Angular\node .__ nicht kompatibel ist. Verwenden Sie entweder die mit node.js gebündelte Version von npm oder eine mit node.js 9 und kompatible node-tar-Version (> 5.5.1 oder <5.4.0) oder node-tar (> 4.0.1) über. C:\Programme\nodejs\node.exe: src\node_zlib.cc: 437: Assertion args.Length () == 7 && "init (windowBits, level, memLevel, Strategie, writeResult, writeCallback," ") "' gescheitert.

Laut @Ilyich habe ich global npm deinstalliert, npm uninstall -g npm Dann habe ich npm install ausgeführt, um mein Paket zu installieren. Es wurde erfolgreich installiert.

2
Sunita

Wenn Sie npm nicht deinstallieren können, können Sie diesen Schritt stattdessen einfach überspringen

Installieren Sie npm https://nodejs.org/de/ neu.

2
kris

Ich habe diese Warnung nach einem Upgrade auf Knoten 10.4.1 gesehen. Danach habe ich npm uninstall -g npm mit -g Flag ausgeführt, um sie global zu entfernen, und der Fehler war verschwunden. Ich denke es hat meine npm auf Version 6.1.0 aktualisiert  enter image description here

2
Mirza Sisic

Wenn Sie beim Erstellen oder Importieren eines Angular-Projekts in einer IDE wie Eclipse dieselben Warnungen erhalten, gehen Sie wie folgt vor:

Datei-> Neu-> Winkel Ändern Sie in dem angezeigten Fenster die Versionen von Nodejs und NPM in "Systeminstallation verwenden".

....__ Wenn der Prozess abstürzt bei "Installieren von Paketen für das Tooling über npm"

Schließen Sie das Terminal in IDE und wechseln Sie manuell in das Projektverzeichnis und führen Sie "npm install" aus.

Aktualisieren Sie das Projekt in IDE

1
Amal Vijayan

Ich hatte ein ähnliches Problem beim Versuch, andere Dinge zu installieren. Und anscheinend war die npm-Version nicht mit meiner Node-Version kompatibel. In meinem Fall hatte ich npm 5.4.2 und node v10.15.0 Am Ende dieses Prozesses hatte ich die Version npm 6.7.0 und node v10.5.0

Erste Option: Ich habe die Version von node und anderen Tools heruntergeladen.

Führen Sie am Terminal den nächsten Befehl mit der zu installierenden Version aus. (Beispiel, wenn wir zu Knoten 8.14.1 wechseln müssen)

1.- Npm install -g [email protected]

Dann führen wir den Befehl aus, um die zu entfernende Version zu deinstallieren.

2.- Npm uninstall -g [email protected]

Danach müssen wir den nächsten Befehl ausführen, um den neuen Pfad festzulegen

3.- Npm update -g [email protected]

Schließlich müssen wir nur die Version ausführen, um zu sehen, ob die Änderungen erfolgreich hinzugefügt wurden

4.- Node -v

In diesem Fall sehen wir die Version 8.14.1 und haben den Vorgang abgeschlossen. Wenn Sie dies für Appium- und Npm-Versionen tun möchten, können Sie ein neues Terminal öffnen und dieselben Schritte ausführen, um die Version zu ändern. Zum Beispiel:

Npm installiere -g [email protected] Npm deinstalliere -g [email protected] Npm aktualisiere -g [email protected] Appium -v

In meinem Fall müssen Sie die nächsten Versionen haben: Node 8.14.1 Npm 6.4.1

Anderer Weg: Um es zu lösen, führe ich einfach im Terminal die nächste Zeile aus.

curl -L https://npmjs.org/install.sh | Sch

Nachdem ich einige Dateien heruntergeladen hatte (es dauerte ungefähr 10 Minuten, bis die Ergebnisse im Terminal angezeigt wurden), konnte ich mit der neuesten und kompatiblen Version beider Tools weiterarbeiten.

In diesem Fall wurde der nächste WARM angezeigt.

npm WARN npm npm unterstützt Node.js v10.15.0 nicht.

npm WARN npm Sie sollten wahrscheinlich auf eine neuere Version von node aktualisieren als wir

npm WARN npm kann keine Zusicherung machen, dass npm mit dieser Version funktioniert.

npm WARN npm Unterstützte Versionen von Node.js sind die neuesten Versionen von 4, 6, 7, 8.

npm WARN npm Die neueste Version finden Sie unter https://nodejs.org/ /Users

1

Nach dem Rat, eine globale Instanz von npm zu deinstallieren, wurde das Problem für mich behoben.

npm deinstallieren -g npm

Dies hat dazu geführt, dass mein System auf die vom Knoten 9.1.0 installierte Version von npm zurückgegriffen hat, wodurch die Warnung behoben wurde.

0
Nitin

Wenn Sie Mac und Brew verwenden, habe ich dieses Problem so gelöst:

Obwohl ich node with brew mit der letzten Version 11.8.0 installiert und erneut installiert habe, wurde offenbar die letzte Version verwendet

fdecollibus $ npm install --global gatsby-cli npm WARN npm npm unterstützt Node.js v11.8.0 npm WARN npm Sie sollten wahrscheinlich auf eine neuere Version des Knotens wie wir npm WARN npm aktualisieren Ich kann keine Zusagen machen, dass npm mit dieser Version funktioniert npm WARN npm Unterstützte Versionen von Node.js sind die neueste Version von 4, 6, 7, 8, 9 . npm WARN npm Sie finden die neueste Version unter https://nodejs.org/ /usr/local/Cellar/node/11.8.0/bin/gatsby -> /usr/local/Cellar/node/11.8.0/ lib/node_modules/gatsby-cli/lib/index.js + [email protected]

npm -v hat mir Version 5.6.0 zurückgegeben. Ich habe daher bemerkt, dass /usr/local/lib/node_modules falsche Zugriffsrechte für root: wheel hatte. Ein Problem wurde nicht behoben: Ich musste den Inhalt des Ordners (cd/usr/local/lib/node_modules und -careful - type rm -rf *) manuell löschen, um den Ordner zu löschen. Dann habe ich den Brew-Deinstallationsknoten und den Brew-Installationsknoten erneut ausgeführt, und schließlich gab npm -v mir 6.5.0 zurück