web-dev-qa-db-de.com

installieren Sie php70-Gd auf Ubuntu

Vor kurzem wurde das neue PHP7 veröffentlicht. Wenn ich jedoch versuche, das Gd-Paket zu installieren, kann die Bibliothek nicht gefunden werden.

Ich habe es durchgemacht

Sudo apt-get install php70-Gd 

und

Sudo apt-get install php70-php-Gd

Hat jemand eine Idee, ob Gd für PHP 7 verfügbar ist?

53
apfz

PHP7-Pakete für Ubuntu einschließlich php7.0-Gd können über PPA for PHP von Ondřej Surý installiert werden:

Sudo add-apt-repository ppa:ondrej/php
Sudo apt-get update

Als nächstes installieren Sie die gewünschte Version:

Sudo apt-get install php7.0-Gd
# or
Sudo apt-get install php7.1-Gd
# or
Sudo apt-get install php7.2-Gd

BEARBEITEN:

Wie MacroMan erklärt , müssen Sie unter Ubuntu 16.04 das Repository nicht mehr hinzufügen. Einfach Sudo apt-get install php7.0-Gd arbeiten lassen.

134
Limon Monte

versuch's einfach

Sudo apt-get install php7.0-Gd 

ich habe es auf diese Weise funktionieren lassen .. Grüße.

16
Emanuel

Im Jahr 2018 gibt es ein Aliase-Paket:

Sudo apt-get install php-Gd

Verwenden Sie dies, um die letzte Version abzurufen.

6
Tino Rüb

meine PHP-Version ist 7.1

Sudo apt-get install php7.1-Gd

dieser Befehl ist für mich Arbeit

Für Ubuntu 16.04.4 LTS

das ist der Befehl:

Sudo apt-get install php7.0-Gd

0
Anoop Saini