web-dev-qa-db-de.com

Paket libapache2-mod-auth-mysql ist nicht verfügbar

Ich versuche, einen LAMP-Stack unter Linux Mint 16 Mate x64 zu installieren, erhalte jedoch immer eine Fehlermeldung, wenn ich diesen Befehl ausführe:

Sudo apt-get install mysql-server libapache2-mod-auth-mysql php5-mysql

Ich verwende die Standard-Quell-Repositorys. Ich habe es geschafft, Apache2, php5 und mysql zu installieren, aber wenn ich die drei Pakete installiere, wird Folgendes ausgegeben:

Das Paket libapache2-mod-auth-mysql ist nicht verfügbar, wird jedoch von einem anderen Paket referenziert.
Dies kann bedeuten, dass das Paket fehlt, veraltet ist oder nur aus einer anderen Quelle verfügbar ist

E: Paket 'libapache2-mod-auth-mysql' hat keinen Installationskandidaten

Aus diesem Grund kann ich die freundliche URL-Funktion nicht verwenden.

16
moderadorkl25

Dies ist ein bestätigter Fehler. Siehe this

3
user1526570

Gemäß diesem Thread wird das libapache2-mod-auth-mysql-Paket nicht mehr gepflegt und nicht benötigt:

Ich habe den Eindruck, dass viele Leute hier gelandet sind, weil sie einen LAMP-Stack installieren möchten. Einige Anweisungen geben an, dass dieses Paket installiert werden sollte, um einen LAMP-Stack zu erhalten. Das ist falsch. Dieses Paket ist nur für die Apache-Authentifizierung gegen MySQL erforderlich (im Gegensatz zum Web-App-Ende, was weitaus häufiger ist). Es scheint mir, dass es im Internet schwebende Anweisungen für die Beförderung von Ladungen gibt.

- Robie Basak

Ich habe gerade einen LAMP-Stack ohne dieses Paket installiert, und es funktioniert gut.

Sudo apt-get install php5-mysql phpmyadmin
16

Ich habe das Paket auch gerade ohne libapache2-mod-auth-mysql installiert. 

Scheint ganz gut zu funktionieren.

Sudo apt-get install mysql-server php5-mysql phpmyadmin
0
Nickel3ack