web-dev-qa-db-de.com

Die aufgerufene Konstruktormethode für WP_Widget in GFWidget ist seit Version 4.3.0 veraltet! Verwenden

The called constructor method for WP_Widget in GFWidget is deprecated since version 4.3.0! Use

__construct()

Hallo,

Ich habe einige interne Serverfehler auf einer Site, die ich gerade mache . Also habe ich Debug aktiviert und der obige Fehler ist der Fehler, den ich erhalte.

Ich bin nicht in der Lage, eine solide Lösung für diesen Fehler zu finden. Kann mir jemand helfen?

1
Grant Smith

Sie verwenden eine veraltete Methode, um Widgets zu deklarieren. WordPress erwartet, dass constructor in PHP 7.0, zugunsten von __construct veraltet sein wird. In der Widgets-API erfahren Sie, wie Widgets heutzutage aufgebaut sind.

Wenn das von Ihnen erwähnte GFWidget von einem Plugin generiert wird, ist dieses Plugin sehr veraltet und sollte wahrscheinlich nicht mehr verwendet werden.

2
cjbj