web-dev-qa-db-de.com

dateutil 2.5.0 ist die mindestens erforderliche Version

Ich verwende das Jupyter-Notebook (Enthought Canopy Python-Distribution 2.7) unter Mac OSX (Version 10.13.6). Wenn ich versuche, Pandas zu importieren (Pandas als pd importieren), erhalte ich die Beschwerde: ImportError: dateutil 2.5.0 ist die mindestens erforderliche Version. Ich habe folgende Paketversionen:

  • Canopy-Version 2.1.3.3542 (64 Bit)
  • jupyter Version 1.0.0-25
  • pandas Version 0.23.1-1
  • python_dateutil Version 2.6.0-1

Ich bekomme diese Beschwerde nicht, wenn ich mit dem Canopy-Editor laufe, daher muss es ein Problem mit der Jupyter-Kompatibilität geben. Hat jemand eine Lösung, wie man das beheben kann? Vor ein paar Monaten war alles in Ordnung, bis ich kürzlich (und gedankenlos) ein Update meiner Pakete zugelassen habe.

1
user1745564

Um dieses Problem zu lösen, musste ich python-dateutil library installieren.

pip install python-dateutil==2.5.0

Damit wurde das Problem gelöst. 

6
GPrathap

Das folgende Kommando arbeitete für mich 

Sudo -H pip install --ignore-installed -U ipython

Sudo -H pip install --ignore-installed -U pyzmq
0
Vinamra Mattoo

Installierte Canopy-Version 2.1.9. Die heruntergeladene Version funktionierte ohne Aktualisierung der vom Canopy Package Manager abgerufenen Pakete. Alle Pakete wurden aktualisiert, aber der "Import pandas as pd" schlug fehl, wenn das Jupyter-Notebook verwendet wurde. Das Notebook-Paket wurde von 4.4.1-5 auf 4.4.1-4 heruntergestuft, wodurch 35 zusätzliche Paket-Downgrades kaskadiert wurden. Erneutes Testen des Imports von Pandas und das Problem scheint verschwunden zu sein. 

0
user1745564