web-dev-qa-db-de.com

python: Bindestrich mit Conda installieren

Ich bin wirklich neu beim Importieren von Paketen in Python. Ich habe Python 3.6.4 auf meinem Computer und versuche, das Dash-Paket dash_core_components zu installieren.

Ich habe versucht, die Anaconda-Eingabeaufforderung einzugeben: conda install dash, (nicht verfügbar für aktuelle Kanäle) Ich habe auch versucht, pip throw conda zu installieren: Conda install pip then pip install dash ..., bekam aber einen Fehler ebenfalls.

Ich bin wirklich neu und weiß ehrlich nicht wirklich, was ich mache. Ich habe ein Pop-Up von Spyder erhalten, als ich es öffne, um zu sagen, dass Sie nie Pip verwenden sollten. Ich verstehe nicht warum ect ... 

Wie kann ich Bindestrich bekommen? Schritt für Schritt 

Danke vielmals

5
mcb

Hier sind die Befehle, um Conda zur Installation von Bindestrich zu bringen:

conda install -c conda-forge dash-renderer
conda install -c conda-forge dash 
conda install -c conda-forge dash-html-components 
conda install -c conda-forge dash-core-components
conda install -c conda-forge plotly

Wenn Sie zur Anaconda-Site gehen und nach dem Paket suchen, erhalten Sie den Befehl conda, um das Paket zu installieren. 

13
Paul D.

Zusammen mit den anderen. Sie können auch Folgendes versuchen: 

import pip

pip.main(['install', 'dash-renderer', '--user'])
pip.main(['install', 'dash', '--user'])
pip.main(['install', 'dash-html-components', '--user'])
pip.main(['install', 'dash-core-components', '--user'])
pip.main(['install', 'plotly', '--user'])

Hinweis: Dadurch werden die Pakete nur für die aktuelle Sitzung installiert. 

oder

Versuchen Sie auch folgendes: 

!pip install dash-renderer
!pip install dash
!pip install dash-html-components
!pip install dash-core-components
!pip install plotly
1
Alpha001