web-dev-qa-db-de.com

Wie installiere ich Pyside für Python 2.7?

Hey, ich bin ziemlich neu bei Pyside und bin nicht sicher, wie ich es herunterladen soll oder Qt? Ich habe einen 64-Bit-Windows-Computer und frage mich, was ich herunterladen muss, nachdem ich Qt heruntergeladen habe, da es eine Checkliste für Qt 5.3, Qt 5.2.1 usw. gibt Darunter befinden sich mehrere Optionen wie MSCV2012 64-Bit und MSCV64-Bit OpenGL. Im Grunde bin ich nur sehr verloren von dem, was ich brauche und kann scheinbar keine Antwort finden. Könnte mich jemand aufklären?

Vielen Dank!

11
zzirrgrizz

Install pip:

  1. Laden Sie pip installer von here herunter und speichern Sie es in einem anderen Verzeichnis als C.
  2. Wenn Sie Ihren Python-Pfad nicht festgelegt haben: folgen Sie this .
  3. Öffnen Sie die Eingabeaufforderung und cd in dem Verzeichnis, in dem Sie das Pip-Installationsprogramm gespeichert haben.
  4. ausführen: python get-pip.py 

Installiere pyside:

  1. Schließen Sie die Eingabeaufforderung und öffnen Sie sie erneut.
  2. ausführen: cd C:\Python27\Scripts
  3. ausführen: pip install -U PySide
17
naheed

PySide unterstützt den Zweig Qt 5.x noch nicht.

Durch einfaches Ausführen von pip install pyside werden Bindungen installiert, die den Zweig Qt 4.8 unterstützen. Daher benötigen Sie diese Version von Qt.

3
Andy

Alle Schritte sind hier , aber zur Vereinfachung geht es hier inline:

Voraussetzungen installieren

Installieren Sie die neueste Pip-Distribution: Laden Sie get-pip.py [bootstrap.pypa.io] herunter und führen Sie sie mit dem Python-Interpreter aus. Installieren von PySide auf einem Windows-System

Um PySide unter Windows zu installieren, können Sie aus den folgenden Optionen auswählen:

Use pip [pypi.python.org] to install the wheel binary packages by issuing the command:
    pip install -U PySide
Use setuptools [pypi.python.org] to install the Egg binary packages by issuing the command (deprecated):
    easy_install -U PySide
Download and install the packages from the PyPI page [pypi.python.org]

Vorausgesetzt, dass Binärdateien keine anderen externen Abhängigkeiten haben. Alle benötigten Qt-Bibliotheken, Entwicklungstools und Beispiele sind enthalten.

Dann können Sie die Qt 4.8.6-Version hier herunterladen:

http://qt-project.org/downloads

Bitte beachten Sie, dass für VS2012 kein Installationsprogramm zur Verfügung steht. Sie sollten daher eine ältere Version oder mingw verwenden. Alternativ können Sie Qt 4 auch selbst bauen.

0
lpapp