web-dev-qa-db-de.com

Fehler in loadNamespace (i, c (lib.loc, .libPaths ()), versionCheck = vI [[i]]): Es gibt kein Paket mit dem Namen 'stringi'.

Wenn ich benutze

library(Hmisc)

Ich erhalte folgende Fehlermeldung

    Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]) : there is no package called 'stringi'
    Error: package 'ggplot2' could not be loaded

Auch wenn ich benutze 

library(ggplot2)

Ich erhalte folgende Fehlermeldung

    Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]) : there is no package called 'stringi'
    Error: package or namespace load failed for 'ggplot2'

Ich habe versucht, 'stringi' Install.packages ("stringi") zu installieren.

Aber irgendwann bekomme ich während der Installation die folgende Fehlermeldung:

    configure: error: in `/private/var/folders/pr/wdr5dvjj24bb4wwnjpg1hndc0000gr/T/RtmpeQ5pXk/R.INSTALL10b94a012cab/stringi':
    configure: error: no acceptable C compiler found in $PATH
    See `config.log' for more details
    ERROR: configuration failed for package 'stringi'
    * removing '/Library/Frameworks/R.framework/Versions/3.2/Resources/library/stringi'

Ich verwende RStudio (Version 0.99.447) und habe R-Version 3.2.1.

6
Marta

Ich habe diese Fehlermeldung erhalten, als ich das Paket " swirl" laden wollte.

Sie können versuchen, das Paket direkt aus cran erneut zu installieren, und fügen Sie ein Argument hinzu, um sicherzustellen, dass alle abhängigen Pakete enthalten sind.

install.packages("swirl", repos="http://cran.rstudio.com/", dependencies=TRUE)
9

verwenden Sie diese install.packages ("package_name", repos = c (" http://rstudio.org/_packages ", " http://cran.rstudio.com " , Abhängigkeiten = TRUE)) 

dies funktioniert, wenn es zuweist, von wo das Paket heruntergeladen werden soll.

1
sanket chaure