web-dev-qa-db-de.com

Fehler nach dem Update: Das Modul "React/Lib/ReactMount" kann nicht aufgelöst werden

Also habe ich versucht, meine Reakt-Webpack-App auf Heroku zu laden, als ich den Fehler bekam, dass sich ReactMount nicht in React/lib/ReactMount befand. Dann habe ich eine Menge verschiedener Sachen ausprobiert und am Ende versucht, ein neues Projekt mit dem gleichen Reakt-Webpack-Generator zu erstellen. Und jetzt bekomme ich den gleichen Fehler, auch wenn ich auf localhost laufe, was bedeutet, dass es irgendwo an einem Update liegen muss, oder?

Weiß jemand etwas davon?

Ich habe folgende Abhängigkeiten:

 "devDependencies": {
"babel-core": "^6.0.0",
"babel-eslint": "^6.0.0",
"babel-loader": "^6.0.0",
"babel-polyfill": "^6.3.14",
"babel-preset-es2015": "^6.0.15",
"babel-preset-react": "^6.0.15",
"babel-preset-stage-0": "^6.5.0",
"bower-webpack-plugin": "^0.1.9",
"chai": "^3.2.0",
"copyfiles": "^1.0.0",
"css-loader": "^0.23.0",
"eslint": "^3.0.0",
"eslint-loader": "^1.0.0",
"eslint-plugin-react": "^6.0.0",
"file-loader": "^0.9.0",
"glob": "^7.0.0",
"isparta-instrumenter-loader": "^1.0.0",
"karma": "^1.0.0",
"karma-chai": "^0.1.0",
"karma-coverage": "^1.0.0",
"karma-mocha": "^1.0.0",
"karma-mocha-reporter": "^2.0.0",
"karma-phantomjs-launcher": "^1.0.0",
"karma-sourcemap-loader": "^0.3.5",
"karma-webpack": "^1.7.0",
"minimist": "^1.2.0",
"mocha": "^3.0.0",
"null-loader": "^0.1.1",
"open": "0.0.5",
"phantomjs-prebuilt": "^2.0.0",
"react-addons-test-utils": "^15.0.0",
"react-hot-loader": "^1.2.9",
"rimraf": "^2.4.3",
"style-loader": "^0.13.0",
"url-loader": "^0.5.6",
"webpack": "^1.12.0",
"webpack-dev-server": "^1.12.0"


"dependencies": {
"core-js": "^2.0.0",
"firebase": "^3.5.2",
"input-moment": "^0.3.0",
"moment": "^2.15.2",
"normalize.css": "^4.0.0",
"react": "^15.0.0",
"react-bootstrap-datetimepicker": "0.0.22",
"react-datetimepicker-bootstrap": "^1.1.2",
"react-dom": "^15.0.0",
"webpack": "^1.13.3"
13

Sieht aus wie Sie und ich im selben Boot waren. Wir haben beide eine alte Version von react-hot-loader auf Version 3.x aktualisiert und eine weitere npm-Installation durchgeführt.

siehe - https://github.com/gaearon/react-hot-loader/issues/417

17
Lutando

Was für mich funktionierte, war die einfache Änderung von reagieren: ^ 15.0.0 auf 15.3.1.

0

Sie müssen react aktualisieren, um das Problem zu beheben. In meinem Fall habe ich keinen heißen Lader verwendet. Ein Upgrade, um zu reagieren, wurde behoben. Derzeit auf 15.4.0

0
Umair Sarfraz