web-dev-qa-db-de.com

Fehler: Modul 'gulp-sass' kann nicht gefunden werden

Beim Kompilieren mit gulp wurde ein Fehler wie folgt angezeigt. Wie kann ich es reparieren?

module.js:339
throw err;
^
Error: Cannot find module 'gulp-sass'
    at Function.Module._resolveFilename (module.js:337:15)
    at Function.Module._load (module.js:287:25)
    at Module.require (module.js:366:17)
    at require (module.js:385:17)
    at Object.<anonymous> (/Applications/XAMPP/xamppfiles/htdocs/flyscoot.com/gulpfile.js:2:12)
    at Module._compile (module.js:435:26)
    at Object.Module._extensions..js (module.js:442:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:311:12)
    at Module.require (module.js:366:17)
59
Htet Win

Machen Sie einfach npm update und dann npm install gulp-sass --save-dev in Ihrem Stammordner, und dann sollten Sie beim Ausführen keine Probleme haben.

70
Dhruv Ghulati

Hast du diese Frage überprüft? 

Mögliche Lösung ist:

rm -rf node_modules/
npm install
18
vtokmak

Ich hatte das gleiche Problem, und ich löse dies npm update. Aber ich erhalte die Nachricht über die Erlaubnis, also renne ich:

Sudo chwon -R myuser /home/myUserFolder/.config

Dadurch werden Berechtigungen für meinen Benutzer festgelegt, die npm-Befehle wie Administrator ausführen. Dann führe ich das nochmal aus:

npm update 

und das:

npm install gulp-sass

Dann wurde mein Problem damit gelöst.

Ich hatte das gleiche Problem auf meinem neuen Windows 10-Computer. Ich musste die Windows Build-Tools mit npm install -g windows-build-tools installieren. ( https://github.com/Microsoft/nodejs-guidelines/blob/master/windows-environment.md#environment-setup-and-configuration )

3
Henning Fischer

Bearbeiten Sie Ihre package.json. Veränderung:

"gulp-sass": "^2.3.2"

zu

"gulp-sass": "3.0.0"

Löschen Sie den Ordner node_modules und führen Sie npm install erneut aus.

Quelle: https://github.com/codecombat/codecombat/issues/4430#issuecomment-348927771

3
rjmccallumbigl

ich war auch mit dem gleichen Problem konfrontiert. Die mögliche Lösung besteht darin, das Modul gulp-sass zu installieren. Wenn Sie jedoch den folgenden Befehl ausführen, npm install -g gulp-sass oder npm install --save gulp-sass, wird dies am Ende des Node-sass-Projekts nicht aktualisiert.

Diese Version von Node-sass fehlt (gibt eine 404 zurück), und Google Web-Starter-Kit v0.6.5 ist seit Dezember 2016 lange Zeit darauf angewiesen. Es funktioniert also schon lange und muss gerade funktionieren verschwunden.

Binäres Herunterladen von https://github.com/sass/node-sass/releases/download/v3.13.1/win32-x64-57_binding.node Kann nicht heruntergeladen werden " https://github.com/sass/node-sass/releases/download/v3.13.1/win32-x64-57_binding.node ":

HTTP-Fehler 404 Nicht gefunden 

Die einzige Problemumgehung besteht im Aktualisieren von node-sass: npm i [email protected] --save-dev, um das Problem zu beheben.

1
Narendra

Versuche dies:

npm install -g gulp-sass

oder

npm install --save gulp-sass
1
maheshSilva

Ich hatte dieses Problem tagelang nach Antworten gesucht. Mein Fehlerprotokoll war diesem npm ähnlich. Der Knoten sass .__ wird einfach nicht installiert. Das einzige Problem war die Knotenversion. Vielleicht kann es einigen von Ihnen helfen.

Ich habe meine Node.js von 9.3.0 auf 6.12.2 heruntergestuft und habe Folgendes ausgeführt:

npm update
1
Ray Macz

Führen Sie im Stammordner, in dem sich package.json befindet, npm outdated aus. Sie erhalten veraltete Pakete mit einigen Details. In diesen Details sehen Sie die aktuelle Versionsnummer des veralteten Pakets.

Öffnen Sie anschließend die Datei package.json und ändern Sie die Versionsnummer des entsprechenden Pakets manuell.

Löschen Sie anschließend den Ordner node_modules und führen Sie npm install aus. Es sollte dieses Problem lösen.

1
Saabbir

Ich hatte auf Ubuntu 18.04 den gleichen Fehler, der mit behoben wurde 

Sudo npm install --unsafe-perm=true
0
moonbyt3

Diejenigen, die diese Fehlermeldung erhalten, downgraden Sie bitte die von Ihnen verwendeten Node.js.

  • Schritt 1 :

    Deinstallieren Sie die von Ihnen verwendete Version und installieren Sie die von Ihnen bevorzugte Version. Ich habe v6.12.3 installiert. Meine vorherige Node.js-Version war v9.4.0.

  • Schritt 2 :

    Node.js herunterladen.

Hoffe das wird funktionieren.

0
User_3535