web-dev-qa-db-de.com

Kann ich XCode 7.3 unter OS X 10.10 Yosemite installieren?

Ich kann mein OS X aus Gründen nicht auf 10.11 aktualisieren. Der XCode 7.3 scheint der erste XCode zu sein, der nicht mit Yosemite 10.10 kompatibel ist.

Ist es jemandem gelungen, XCode 7.3 für Yosemite zu verwenden? (Was ist das wichtige Update für XCode, das has , damit es nicht mit Yosemite kompatibel ist?)

12
Thyselius

Leider nein, das geht nicht.

Sie benötigen OS X 10.11 oder höher (El Capitan) seit dem 21. März.

Sie aktualisieren also entweder von Yosemite auf El Capitan oder bleiben bei Ihrem aktuellen Xcode.

Wichtig? Ich werde nicht so viel sagen ... iOS 9.3 und Swift 2.2, wenn Sie das mögen ... Mit den restlichen Betriebssystemen. Der Rest ist ziemlich gleich, es ist kein großes Update.

11
Helen Wood

WENN Sie hier sind, weil Sie Ihr Gerät (iPhone, Apple TV usw.) aktualisiert haben und Ihre Apps nicht mehr auf dieses aktualisierte Gerät exportieren können, gibt es eine Problemumgehung!

Sie können tatsächlich die neueste Version von iOS XCode SDK von einer neueren Version von XCode in Ihre ältere Version von XCode kopieren.

1 Benennen Sie Ihre alte XCode.app in XCode7.app um und installieren Sie die neueste Version von XCode (ja, Sie können mehrere Versionen haben).

2 Besorgen Sie sich den Ordner in Ihrem neuen XCode-Paket-Inhaltsordner: /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/10.3 \ 

Fügen Sie es an derselben Stelle wie in XCode 7.3 oder 8.2 hinzu/Applications/Xcode7.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/

Starten Sie XCode neu und Sie können weiterarbeiten!

0
Thyselius